reklama
Aktuality  |  Články  |  Recenze
Doporučení  |  Diskuze
Grafické karty a hry  |  Procesory
Storage a RAM
Monitory  |  Ostatní
Akumulátory, EV
Robotika, AI
Průzkum vesmíru
Digimanie  |  TV Freak  |  Svět mobilně
HFX9 (276)|2.5.2008 20:19
Ocekavam behem tydne prichod sata backplatu ktery umi jak raid, tak prave hot-swap a tak by me zajimalo co vse musim mit pozapinane a jak vlastne ten hotswap funguje (jestli je nejaky special postup pro odpojovani disku za behu pc, nebo staci jen vypnout disk a odpojit atd.).

Tak nejak tusim ze bych mel mit v biosu zapnute u radice rezim AHCI nebo aspon RAID, ale bohuzel to nemam a tak moje otazka smeruje na to jestli je nejaka moznost jak tuhle funkci v biosu zapnout a vyuzivat aniz bych musel reinstalovat Visty? Protoze kdyz to v biosu prepnu do AHCI tak mi Visty nenabehnou.

Vim ze o AHCI se tu uz mluvilo, ale mozna nekomu toto tema pomuze kdyz tu bude vse pohromade i s vysvetlenim funkce hotswapu.
pavel_p (993)|2.5.2008 21:12
Na Intel ICH9R chipsetu jsou pro hot swap (hot plug) tři podmínky:
- povolit v BIOSu AHCI
- nainstalovat Intelácké drivery (Intel Matrix Storage Drivers, nenechat default ve Vistách - ty mají paradoxně vyšší verzi)
- verze BIOSu, která to podporuje (dodatek - AHCI samo o sobě nestačí, viz. changelog biosu desky Intel DP35DP: http://downloadmirror.intel.com/15596/ENG/DP_0413_ReleaseNotes.pdf)

Povolení AHCI za běhu: http://support.microsoft.com/kb/922976 (funguje v Opeře a MSIE6, ne ve Firefoxu a MSIE7 - zabít microsoft za úpravu stránek)

Btw backplate umí RAID a hotswap? Backplate je jen vyvedení konektorů ze skříně a podporovat to musí chipset, ne? Nebo myslíš backplatem přímo PCI(-E) kartu? Ta má pak vlastní BIOS.

Jestli funguje hotswap v raidu a automatická rekonstrukce pole intel nezmiňuje, ale u domacího PC je to jedno ... pokud disk odejde, což je nepravděpodobné, tak holt pc na 10min vypneš a vyměníš za nový.


Mě teda eSATA disk fungoval spíš náhodně, takže bezpečné odebrání není ověřeno, ale matně si pamatuju, že je to analogické s USB připojením.
HFX9 (276)|6.5.2008 08:47
Tak jsem uspesne namontoval backplate (je to opravdu jen vyvedeni konektoru, neni k tomu zadna karta), ale kdyz nastartuji pc s jednim hdd a potom zapnu druhy nikde se mi neukaze, myslel jsem si ze to ma fungovat jako s usb klicenkou, proste spustim dalsi disk a visty si ho najdou a zprovozni abych s nim mohl pracovat.

AHCI mam povoleno v biosu, drivery nainstalovany ve Vistach (sami si je stahnuli) ale nejak to nefunguje.

Poradi nekdo co s tim?

Desku mam gigabyte EP35-DS3
johny__g (6387)|6.5.2008 09:26
Máš připojené i napájení disku?

Na který řadič to připojuješ? Integrovaný v ICH9 nebo ten JMicron?
HFX9 (276)|6.5.2008 09:59
[QUOTE=johny__g;119715]Máš připojené i napájení disku?

Na který řadič to připojuješ? Integrovaný v ICH9 nebo ten JMicron?[/QUOTE]

Napajeni samozrejme zapnute mam (disk se fyzicky roztoci) a mam to napojene do ICH9
johny__g (6387)|6.5.2008 10:20
Tak to zkus dát na ten JMicron.
HFX9 (276)|6.5.2008 14:51
Zkusim to vecer, ale stejne by to melo fungovat i na tom ICH9, nebo se pletu?
HFX9 (276)|6.5.2008 19:55
Tak kdyz jsem to dal na JMicron a nastavil v biosu na tom radici AHCI tak hot swap funguje, ale je mi zahadou proc nejde na tom ICH9 radici?

Nejaky napad jak to rozchodit i na ICH9 radici ?
HFX9 (276)|6.5.2008 20:06
Tak tohle je pro mne docela zajimave zjisteni:

ICH9, ICH8, ICH7 and ICH6-based chipsets, as well as ICH5 and ICH5R-based chipsets, do not use AHCI

Je to primo ze stranek intel.com
http://www.intel.com/support/chipsets/imst/sb/CS-012304.htm

Pokud to tedy dobre chapu tak ICH9 by nemel umet AHCI a tim padem ani hot swap?
johny__g (6387)|7.5.2008 10:20
Pod WinXP se mi AHCI na ICH9 rozjet nepodařilo (a podle vyjádření přímo od GB to opravdu nejde), ale nevadí mi to, hot swap nepoužívám. Ale měl jsem dojem, že pro Visty už AHCI fungovat má. Výkonem je JMicron na tom podobně jako ICH9, takže jestli ti to na něm jede, nechal bych to tak.
HFX9 (276)|7.5.2008 13:11
No me jen prijde dost blby, ze v biosu muzu u toho ICH9 AHCI zapnout, ale potom se mi disk hlasi jako UltraDMA 8 a v tomto rezimu nepracuje korektne. Takze ho musim vyuzivat jen v rezimu IDE a tim padem UltraDMA 5, coz znamena mensi prenesove rychlosti :-(

Proc vubec bios dovoluje to abych AHCI zapnul u ICH9 radice, kdyz podle intelu na tomto typu radice AHCI fungovat nema?

Chtel jsem instalovat i primo od intelu ten jejich matrix software, ale pri spusteni instalace mi to napsalo ze nemam potrebny hardware a konec.

Zajimalo by mne jestli ma nekdo s ICH9 AHCI a HOTSWAPem stejny zkusenosti
johny__g (6387)|7.5.2008 14:39
AHCI u ICH9 se trochu rozebíralo tady, jinak oficiální vyjádření od Gigabyte:

[QUOTE]"To enable hot plug capability for the SATA connectors controlled by the ICH9 South Bridge, you must install Windows Vista (on ICH9, hot plug is supported in Windows Vista only) and configure the SATA connectors for AHCI mode. (Refer to manual Chapter 2, "BIOS Setup," "Integrated Peripherals," for details on enabling AHCI.)"[/QUOTE]

[QUOTE]Dear Sir,

Thank you for your kindly mail and picture. About the PCI device you mentioned, it is Intel ICH9 AHCI function. Please disable it if you did not install WIndows VIsta.
[/QUOTE]

Přenosové rychlosti s/bez AHCI jsou stejné, nemá to na nic vliv. UDMA 8 je nějaký nesmysl, nejvyšší je UDMA 6 = ATA133. Ale v praxi není ani mezi ATA 100 vs. 133 rozdíl.
mech13 (5526)|7.5.2008 14:44
no ja teda nevim, ale zkusil jsi proste ten hot swap? ja jednu na ICH8 (??? snad? 965P), win XP, zadne AHCI ani nic takovyho jsem nezapinal a hot-swap natvrdo jede. proste tam disk narvi za provozu a uvidis, pri trose stesti to pokouse (snad jen je potreba mit zaplou autodetekci v biosu - tj nemit na prislusnem portu disabled)
HFX9 (276)|7.5.2008 14:52
[QUOTE=mech13;120004]no ja teda nevim, ale zkusil jsi proste ten hot swap? ja jednu na ICH8 (??? snad? 965P), win XP, zadne AHCI ani nic takovyho jsem nezapinal a hot-swap natvrdo jede. proste tam disk narvi za provozu a uvidis, pri trose stesti to pokouse (snad jen je potreba mit zaplou autodetekci v biosu - tj nemit na prislusnem portu disabled)[/QUOTE]

Ja pokud tam ten disk "narvu" jak rikas, tak se vubec nic nestane, system ho proste na tom ICH9 radici nevidi, jako by vubec pripojeny nebyl. V biosu nastaveno na vsech kanalech AUTO.

Hotswap funguje jen a pouze na Jmicronu a to v biosu musi byt u nej nastaveny rezim z IDE na AHCI

Takze asi tak
HFX9 (276)|7.5.2008 14:57
[QUOTE=johny__g;120002]AHCI u ICH9 se trochu rozebíralo tady, jinak oficiální vyjádření od Gigabyte:
Přenosové rychlosti s/bez AHCI jsou stejné, nemá to na nic vliv. UDMA 8 je nějaký nesmysl, nejvyšší je UDMA 6 = ATA133. Ale v praxi není ani mezi ATA 100 vs. 133 rozdíl.[/QUOTE]

No myslim ze je UDMA 7 = ATA 150.
Vim ze UDMA 8 je blbost ale ve chvili kdy zapnu na ICH9 AHCI, tak se mi disk v HD Tune hlasi jako UDMA8 a pri kopirovani z disku na disk se mi to v polovine kouslo, tak jsem to ICH9 prehodil na IDE (vypnul AHCI) a uz to jelo korektne, ale mensi rychlosti (rychlost klesla cca o 1/3)

Pokusim se jeste dneska naisntalovat visty primo se zapnutym AHCI a uvidim co to udela, ja totiz to AHCI dohraval az po instalaci, tak jestli to na to nemuze mit nejaky vliv.
pavel_p (993)|7.5.2008 22:57
Jestli je to ICH9R a ne ICH9 (u toho modelu desky je to 30000 vs. 20000 nalezených stránek na googlu, tudíž nevím), tak opravdu pomůže instalace Intel Matrix Storage: http://downloadcenter.intel.com/filter_results.aspx?strTypes=all&ProductID=2101&OSFullName=Windows+Vista%2A+32&lang=eng&strOSs=164&submit=Go%21

Ve vistách je driver v 8.xxxxx, ale staršího data, takže se z jejich pohledu jedná dle verze o downgrade. Na desce Intel DP35DP mi to pomohlo (ta má na řadiči JMicron jen IDE)

Předpokládám UDMA7~SATA150; UDMA8~SATA300~SATAII

EDIT:
Zvláštnost ... správce zařízení zobrazuje ICH9, i když je to ICH9R
Spolehlivější zdroj je: http://pci-ids.ucw.cz/iii/?i=8086 a vyhledat co vidíš u řadiče na záložce podrobnosti pod vlastností id hardwaru. Např. vendor: 8086, device: 2922 odpovídá v databázi "82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller". Podle tohoto seznamu se zobrazuje název zařízení v Linuxu.
HFX9 (276)|7.5.2008 23:34
Tak jsem preinstaloval cele Visty a mam dva poznatky:

Po preinstalaci primo s radicem nastavenym na AHCI, se disk hlasi jako UDMA7 a v pripade ze pripojim disk na ICH9 tak se sice nic nestane, ale kdyz dam ve spravci zarizeni vyhledat zmeni hardware, tak to ten nove pripojeny disk najde a mohu s nim pracovat, ale nasledne nelze bezpecne odebrat.

Pokud pripojim disk na Jmicron, tak funguje vse naprosto korektne, disk se sam ukaze v tomto pocitaci a lze take bezpecne odebrat.

Tak to je z meho dnesniho testovani vse.

EDIT: a mam opravdu jen ICH9 bez R
kane.shw (1231)|8.5.2008 17:00
Jak to tak čtu, tak se musím také podělit o jeden můj poznatek.

Mám desku GA-EP35-DS3R a před nedávnem jsem měl pouze na pár hodin (!!!) k dispozici externí disk WD My Book 2 o kapacitě 1TB, který jsem připojoval přes eSATA.

Prve jsem ho připojil do fialového konektoru (Jmicron) a disk se tvářil jako USB flash disk (bezpečné odebírání atp.). Když jsem ho připojil do oranžového (ICH9), tak se choval jako klasický interní disk. Nic jsem nenastavoval ani v BIOSu ani nikde jinde, prostě nebyl čas to nějak zvláť řešit;).

Co mě, ale zarazilo, bylo to, že HDTune nebyl schopen provézt ani Benchmark ani Scan disku :notsure, když byl připojen právě přes fialový konektor (Jmicron). Proto jsem ho také posléze přepojil do oranžového (ICH9), kde proběhl test i scan zcela korektně.

Jakmile se mi tento disk dostane zase do ruky - a ono to jednou zase přijde :D - tak na to mrknu podrobněji, zatím tedy jen tento strohý poznatek. Třeba ti/vám to pomůže :thumb